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Preface 
The FoldX plugin for YASARA is a software package to access and run FoldX 
commands in YASARA.  

FoldX is a molecular modeling and protein design software program that calculates 
energy differences that come close to experimental values. FoldX can minimize a PDB 
structure, mutate one or more residues to new residues, do protein stability analysis, 
protein-protein interaction energy analysis and much more. FoldX is widely used to 
predict the effect of mutations on the stability of a protein or to predict the effect on 
protein-protein binding.  

YASARA is a molecular-graphics, -modeling and -simulation program that finally makes 
it really easy to answer your biological questions. The 3D graphics and intuitive interface 
make it a very user-friendly protein and nucleic acid analysis package. It is also easily 
extendable by means of plugins.  

FoldX is normally run from the command line without graphics. By installing the FoldX 
plugin for YASARA, you can access the most important FoldX tools at the touch of a 
button in the 3D graphical YASARA interface. You directly see the results of your FoldX 
protein analysis on screen.  

FoldX, YASARA and the FoldX plugin for YASARA are all available for Linux, 
MacOSX and Windows.  

This manual is a guide through the installation and usage of the FoldX plugin for 
YASARA.  

The web manual can be found at http://switch.vub.ac.be/foldxyasara 

Have fun!  

http://switch.vub.ac.be/foldxyasara
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Installation and first use 
Installation  

1. Download and install YASARA  

The FoldX plugin for YASARA can be used in any stage of YASARA: View, 
Model, Dynamics, Structure, Twinset. YASARA View is the free version of 
YASARA and can be downloaded from http://www.yasara.org/viewdl.htm after 
free and simple registration. You will receive a download link in your mailbox 
shortly after registration. Installation instructions are in the mail from YASARA.  
 
The plugin only works from YASARA version 10.11.22 and higher. 
Upgrading to the latest YASARA is strongly recommended.  

2. Download and install FoldX  

The FoldX plugin for YASARA requires that you have FoldX installed on your 
computer. For compatibility purposes you need to download the latest version 
(FoldX 3 Beta 5, expires in 2012) from http://foldx.crg.es after free and simple 
registration for academic users.  
Commercial users should contact CRG tech transfer to acquire a license. A trial 
version can be obtained first.  
Install FoldX by unzipping the file you just downloaded. This will unzip two files: 
an executable file and a file called 'rotabase.txt'. Both are necessary.  

3. Download and install Python  

On Linux and MacOSX machines Python is installed by default. Windows users 
can download Python from http://www.python.org/download or install it from 
within YASARA by clicking:  

Help > Install program > Python 

4. Download and install the FoldX plugin for YASARA  

The plugin can be downloaded HERE.  
The content of the plugin has to be extracted in the yasara/plg folder (or 
yasara\plg folder for Windows users). After doing that you should have these 8 
files in your yasara/plg folder:  

1. foldx.py  
2. foldxaminoacids.txt  
3. foldxanalysecomplex.py  

http://www.yasara.org/viewdl.htm
http://foldx.crg.es/
http://pasteur.crg.es/portal/page/portal/Internet/HIDE-Technolgy_Transfer
http://www.python.org/download
http://switch.vub.ac.be/foldxyasara/images/8/86/Foldxyasara.zip
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4. foldxbuildmodel.py  
5. foldxplotoutput.py  
6. foldxrepair.py  
7. foldxstability.py  
8. foldx.cnf  

First use  

Start YASARA and load a structure. Now go to  

Analyze > FoldX > Configure plugin 

In the first browser window select the FoldX executable file and in the second browser 
window select the rotabase.txt file that came with FoldX.  

As long as you don't change the location of those files or you don't overwrite the 
foldx.cnf file (be careful when unzipping a new version directly in the plg folder), this 
procedure has to be done only once.  
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Citing the plugin 
If you publish results that were obtained with the FoldX plugin for YASARA, please cite:  

The FoldX plugin  

Van Durme J, Delgado J, Stricher F, Serrano L, Schymkowitz J and Rousseau F. 
A graphical interface for the FoldX forcefield. 
Bioinformatics. Advance Access published April 19, 2011, 
doi:10.1093/bioinformatics/btr254 

Click HERE to access the abstract and full plugin paper on the Bioinformatics website.  

 
YASARA  

Krieger E, Koraimann G, Vriend G.  
Increasing the precision of comparative models with YASARA NOVA--a self-parameterizing 
force field. 
Proteins. 2002 May 15;47(3):393-402. 

If you use YASARA for anything else than molecular graphics, please consult your 
YASARA documentation for the proper citation(s).  

http://dx.doi.org/10.1093/bioinformatics/btr254
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FoldX tools in YASARA 
Preface 
In this section we explain the various FoldX [1] functionalities inside YASARA. It is 
recommended that you have practised with YASARA and FoldX before. But don't worry, 
all commands are straightforward and easy to use. That's the point of the plugin. 
However, we will refer to YASARA specific nomenclature such as Objects and 
Molecules. Their definition can be found in the YASARA documentation on your 
computer in yasara/doc/index.html.  

Sometimes we will not explain all details on the FoldX commands provided in this plugin 
but refer to the detailed FoldX manual which can be downloaded at http://foldx.crg.es.  

The output of FoldX calculations is always printed to the YASARA console when the 
plugin ends. The console should open by default, but when it fails, you can enter the 
console by pressing the spacebar once or twice.  

 
FoldX tools menu in YASARA 

All FoldX tools in YASARA can be accessed by clicking:  

Analyze > FoldX > ... 

http://switch.vub.ac.be/foldxyasara/index.php/File:Foldx_menu.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Foldx_menu.png�
http://foldx.crg.es/
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Context menus  

A subset of the FoldX tools is also accessible via the atom-, residue- and object-context 
menus. The atom context menu appears when an atom is selected and the right-mouse 
button is clicked. The residue context menu appears when a residue in the sequence 
selector is right-clicked (see screenshot below).  

 
Residue-context menu appears when a residue in the sequence selector is right-clicked 

This way of accessing some of the FoldX tools has been made to speed up quick analysis, 
as the right-clicked atom or residue is automatically selected for analysis. When selecting 
calculations on a YASARA Object through these context menus, the selected Object is 
the one the right-clicked atom or residue belongs to.  

The object context menu appears when an object is right-clicked in the HUD (see 
screenshot below).  

http://switch.vub.ac.be/foldxyasara/index.php/File:Context_residue.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Context_residue.png�
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Object-context menu appears when an object in the HUD is right-clicked 

FoldX energies  

The main focus of FoldX is the prediction of free energy changes, e.g. what happens to 
the free energy of the protein when we mutate an Asp to a Tyr? FoldX will then calculate 
the free energy of the wild type (WT) and the mutant (MT) and make the difference:  

ΔΔG(change) = ΔG(MT) - ΔG(WT)  

FoldX is trained to make ΔΔG(change) approach experimental values. It is important to 
realize that ΔG(WT) and ΔG(MT) are meaningless numbers as such. These do not 
correlate with experimental values. Only ΔΔG(change) does.  

As a rule of thumb we use:  

ΔΔG(change) > 0 : the mutation is destabilizing  

ΔΔG(change) < 0 : the mutation is stabilizing  

The error margin of FoldX is approximately 0.5 kcal/mol, so changes in that range are 
insignificant.  

Calculation speed  

The calculations were performed on a Linux pc with an Intel Core Duo2 2,8GHz 
processor with 3MB of RAM memory. Repairing a structure is the most computationally 
intensive procedure as all sidechains have to be re-evaluated for their energy. This takes 
on average 2-5 minutes for a protein of about 300 residues. One point mutation takes a 
few seconds for mutating to small amino acids to 1-2 minutes for larger amino acids with 

http://switch.vub.ac.be/foldxyasara/index.php/File:Context_object.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Context_object.png�
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more degrees of freedom in their sidechain (R,K). Calculation of interaction energy is a 
matter of seconds.  

Protein, DNA, nucleotides and metals recognized by 
FoldX  

Below are lists of molecules that are recognized by FoldX. This implies that FoldX can 
include these in the free energy predictions. For example, it is thus possible to predict the 
effect of an amino acid mutation on DNA binding or metal binding [2].  

List of amino acids  
Name  3-letter 1-letter 

Alanine  Ala  A 
Arginine  Arg  R  

Asparagine  Asn  N  
Aspartic acid  Asp  D 

Cysteine  Cys  C  
Phenylalanine  Phe  F 

Glutamine  Gln  Q 
Glutamic acid  Glu  E 

Glycine  Gly  G 
Histidine  His  H 
Isoleucine  Ile  I 
Leucine  Leu  L 
Lysine  Lys  K 

Methionine  Met  M 
Proline  Pro  P 
Serine  Ser  S 

Threonine  Thr  T 
Tryptophan  Trp  W 

Tyrosine  Tyr  Y 
Valine  Val  V 

Phosphotyrosine  Ptr  y 
Phosphothreonine Tpo  p 

Phosphoserine  Sep  s 
Sulphotyrosine  Tys  z 
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List of DNA nucleotides  

Name  PDB file code 1-letter 
Adenosine A  a  
Guanine G  g  
Cytosine C  c  

Thymidine  T  t  
6-methylated adenosine 6MA  b  
5-methylated cytosine  5CM  d 

 

List of nucleotides  
Name  PDB file code 

Adenosine diphosphate ADP  
Adenosine triphosphate ATP  
Guanosine diphosphate GDP  
Guanosine triphosphate GTP  

 

List of metals  
Name  PDB file code 

Calcium CA  
Magnesium MG  
Manganese MN  

Sodium  NA  
Zinc  ZN  
Iron  FE  

Copper  CU  
Cobalt  CO  

Potassium  K  

 

Waters  
Name PDB file code 
Water HOH  
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Fix residues  
FoldX commands such as RepairPDB (the FoldX energy minimization) and BuildModel 
(make mutations or complete models) will move residues by default. RepairPDB 
minimizes a structure by rearranging the sidechains to find a new energy minimum. 
BuildModel will rearrange neighbouring residues of a mutation spot to optimize the 
mutated protein.  

There are cases where the user does not want certain residues to move, either during 
RepairPDB or BuildModel.  

The 'Fix residues' command lets you select residues that will not move during a RepairPDB 
or BuildModel. 

The fixed residues will be colored in yellow (see screenshot). Do not confuse Fixed 
residues from the FoldX plugin with fixed residues from the simulation menu from 
YASARA (only in YASARA Dynamics and YASARA Structure). These are totally 
independent.  

 
Fixed residues are colored in yellow 

http://switch.vub.ac.be/foldxyasara/index.php/File:Fix_residues.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Fix_residues.png�
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Free residues  

In case you want to unfix one or multiple residues that have previously been fixed with 
the Fix residues command, you can use the Free residues command.  

The 'Free residues' command unfixes previously fixed residues. These freed residues will 
be allowed to move during a RepairPDB or BuildModel. 

Repair object  

This command executes the FoldX RepairPDB command. RepairPDB minimizes the 
energy of a protein structure by rearranging the amino acid sidechains in order to get a 
better free energy of the protein (see screenshot). RepairPDB only rearranges sidechains, 
not the backbone. Residues that should not be rearranged should be fixed by using the 
'Fix residues' command.  

'Repair object' does an energy minization of the selected Object by running the FoldX 
RepairPDB command and is required to get accurate  
 
results when subsequently calculating the stability, interaction energy or when making 
mutations with FoldX. 

 
Result of a RepairPDB run with the repaired structure in green 

The way RepairPDB operates is the following:  

1. First it looks for all Asn, Gln and His residues and flips them by 180 degrees. This 
is done to prevent incorrect rotamer assignment in the structure due to the fact that 
the electron density of Asn and Gln carboxamide groups is almost symmetrical 

http://switch.vub.ac.be/foldxyasara/index.php/File:Repair_object.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Repair_object.png�
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and the correct placement can only be discerned by calculating the interactions 
with the surrounding atoms. The same applies to His.  

2. We do a small optimization of the side chains to eliminate small VanderWaals’ 
clashes. This way we will prevent moving side chains in the final step.  

3. We identify the residues that have very bad energies and we mutate them and 
their neighbours to themselves exploring different rotamer combinations to find 
new energy minima.  

We refer to the FoldX manual for an even more detailed explanation on repairing PDB 
structures.  

Stability of object  

The FoldX Stability command calculates the free energy of unfolding (delta G). This is 
the difference in free energy between the folded state and the unfolded state.  

'Stability of object' calculates the free energy difference of a selected Object. 

To get the most accurate results, we recommend to use the Repair object command first.  

It should be noted that stability values (in contrast to stability changes) do not reflect 
experimental values, but large (> 10kcal/mol) positive values might indicate a problem in 
the overall architecture of the structure).  

 
The stability in kcal/mol is shown in the YASARA console 

http://switch.vub.ac.be/foldxyasara/index.php/File:Stability_object.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Stability_object.png�
http://switch.vub.ac.be/foldxyasara/index.php/FoldX_tools_in_YASARA#Repair_object
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Alanine scan of object  

'Alanine scan of object' mutates every residue in an object to alanine and calculates the 
energy difference upon mutation to alanine. 

The results of the alanine scan are displayed in the console (see screenshot). Press the 
spacebar twice to enlarge the console. The same results are also listed in a tab-delimited 
text file called FOLDXSUMMARY.out in the cache folder. This file can be saved in a 
custom folder alone or together with all other output files using the option Save last 
calculation.  

 
Result of an alanine scan is displayed in the console 

To get the most accurate results, we recommend to use the Repair object command first.  

Energy analysis of object  

'Energy analysis of object' prints a full energy decomposition per residue in the 
selected objects. 

This command runs the FoldX SequenceDetail command and prints the energy 
contribution per residue in the structure as well as a decomposition of the per-residue 
energy in its separate terms. Other per-residue information such as dihedral angles, 
residue burial and secondary structure is also printed.  

http://switch.vub.ac.be/foldxyasara/index.php/File:Alanine_scan_object.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Alanine_scan_object.png�
http://switch.vub.ac.be/foldxyasara/index.php/FoldX_tools_in_YASARA#Save_last_calculation
http://switch.vub.ac.be/foldxyasara/index.php/FoldX_tools_in_YASARA#Save_last_calculation
http://switch.vub.ac.be/foldxyasara/index.php/FoldX_tools_in_YASARA#Repair_object
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The results are stored in the FOLDXSUMMARY.out file which can be saved by choosing 'Save 
last calculation'. 

To get the most accurate results, it is necessary to run the Repair object command first.  

Interaction energy of molecules  

This option executes the FoldX AnalyseComplex command. It determines the interaction 
energy between 2 selections of Molecules. 
It is allowed to select more than 1 molecule in each selection window. E.g. if you select 
molecules A and B in the first selection and C in the second selection, A and B are joined 
in one entity AB. The interaction energy between AB and C is then calculated. The 
results are displayed in the console.  

The way it operates is by unfolding the selected targets and determining the stability of 
the remaining molecules and then subtracting the sum of the individual energies from the 
global energy. In case there is a metal bound between the two molecules it will assign it 
to the one which makes the stronger interactions with the metal. So, clearly:  

'Interaction energy of molecules' calculates the interaction energy between two 
selections of Molecules. 

As an extra, this command also lists the residues at the interface of the selected molecules 
in the console.  

 
Result of interaction energy calculation between joined molecules ABD and molecule C. 
Also the interface residues are printed. 

http://switch.vub.ac.be/foldxyasara/index.php/File:Interaction_energy_molecules.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Interaction_energy_molecules.png�
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To get the most accurate results, we recommend using the Repair object command first.  

Mutate residue  

'Mutate residue' mutates one amino acid residue to one or more new amino acid residues 
using FoldX BuildModel. 

This command executes the FoldX BuildModel command [3]. Subsequently the user is 
presented with following menus:  

Residue selection menu 

 Here you can select one residue to mutate to other residue types  

 
Residue selection menu 

 

Select FoldX routines 

 RepairPDB: repairs the structure as in Repair object before making the 
mutation. The mutations will be made using this repaired structure.  

 Calculate stability change: calculates and display the stability change 
upon mutation. So the difference in stability between mutant and wild type 
structure. This predicts whether a mutation will stabilize or destabilize a 
structure. Stabilizing mutations will have a negative value (ddG).  

 Calculate interaction energy change: this option should only be used 
when the Object contains multiple Molecules. It calculates and displays 

http://switch.vub.ac.be/foldxyasara/index.php/File:Mutate_residue_1.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Mutate_residue_1.png�
http://switch.vub.ac.be/foldxyasara/index.php/FoldX_tools_in_YASARA#Repair_object
http://switch.vub.ac.be/foldxyasara/index.php/FoldX_tools_in_YASARA#Repair_object
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the interaction energy change between any possible pair of Molecules in 
the Object after mutation. 

 
Selection menu for FoldX commands 
Note: the output will contain a column named 'corrected interaction energy'. This 
is the interaction energy corrected for intrachain clashes. See the FoldX manual 
for more information.  

 

Select new amino acid residue(s) 

 here you can select the residues that should replace the original residue. 
Each selected residue will result in a new model made with FoldX.  

 

http://switch.vub.ac.be/foldxyasara/index.php/File:Mutate_residue_2.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Mutate_residue_2.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Mutate_residue_3.png�


 19

Selection menu for new residues 

 

Set FoldX options (1) 

 Move neighbours: this lonely option is on by default and allows residues 
around the mutation spot to be moved to accomodate the new residue. In 
case you don't want these neighbours to move, uncheck the option.  

 Zoom to mutation site: checking this option will automatically close-up to 
the mutation site for quick visual inspection.  

 Show disrupted and new hydrogen bonds: checking this option adds 
hydrogens to the structure and shows the hydrogen bonds in the wild type 
and mutated structure.  

 Show VdW clashes in WT and mutant: checking this option will highlight 
in red Vander Waals clashes in wild type and mutant structures.  

 
First options menu 

 

Set FoldX options (2) 

 Number of runs: This option tells the algorithm how many times it should 
do the specified mutations. Normally it should be set to 1. However, 
sometimes it can be set to higher numbers (typically 5) to see if the 
algorithm has achieved convergence, or in other words if the solution 
offered is the optimal or a trapped solution. Each run will result in an 
additional model for a certain mutation.  

 Temperature: Temperature (K).  

http://switch.vub.ac.be/foldxyasara/index.php/File:Mutate_residue_3.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Mutate_residue_4.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Mutate_residue_4.png�
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 pH: At the moment only used for pH effects on metal binding. Will not 
affect the protonation of charged groups in this version.  

 Ionic strength: Ionic strength of the solution (M) x 100. The multiplication 
by 100 was needed for YASARA implementation since no decimal 
numbers are allowed in menus. So the default of 5 is actually 0.05M.  

 Van der Waals design: When set to 2, it considers rotamer penalizations 
due to internal clashes, maximum penalization for interresidue 
VanderWaals’ clashes, a ceiling for the VanderWaals’ clashes between 
two atoms of 5 kcal/mol and strict H-bond geometry. When set to zero 
there is a weak rotamer penalization, there is a ceiling for the 
VanderWaals’ clashes of 1 kcal/mol and we use a relaxed H-bond 
geometry. This option should be set to 0 when doing an Ala scanning 
mutagenesis of a protein. Whenever doing design, or repairing a PDB, it 
should be set to 2 (default in the RepairPDB in this plugin).  

 
Second options menu 

 
After the mutation design the Repaired structure (if selected) and all the runs of the 
mutations will be loaded into YASARA as new Objects. All of these will be structurally 
aligned (superposition) for direct comparison (see screenshot below).  

The requested output (stability change, interaction energy change) will be plotted in the 
YASARA console (see screenshot below). The individual energies as well as the average 
energy over all runs will be printed.  

http://switch.vub.ac.be/foldxyasara/index.php/File:Mutate_residue_5.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Mutate_residue_5.png�
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Result of a mutation from Val to Arg and Ile in 3 runs each. Each mutation is loaded as a 
new object and the energy difference is printed in the console 

The same results are also listed in a tab-delimited text file called FOLDXSUMMARY.out 
in the cache folder. This file can be saved in a custom folder together with all other 
output files using the option Save last calculation.  

All models and repaired structures can be saved as PDB files by clicking (for each object 
separately):  

File > Save as > PDB File 

Or you can save the entire YASARA scene keeping all Objects, colors and orientation 
including superposition by clicking:  

File > Save as > YASARA Scene 

To get the most accurate results, we recommend to use the Repair object command first.  

For reference, this table lists all residues with their 1-lettercode and 3-lettercode as 
used in the plugin  

Name  3-letter 1-letter 
Alanine  Ala  A 
Arginine  Arg  R  

Asparagine  Asn  N  
Aspartic acid  Asp  D 

Cysteine  Cys  C  

http://switch.vub.ac.be/foldxyasara/index.php/File:Mutate_residue_6.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Mutate_residue_6.png�
http://switch.vub.ac.be/foldxyasara/index.php/FoldX_tools_in_YASARA#Save_last_calculation
http://switch.vub.ac.be/foldxyasara/index.php/FoldX_tools_in_YASARA#Repair_object
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Phenylalanine  Phe  F 
Glutamine  Gln  Q 

Glutamic acid  Glu  E 
Glycine  Gly  G 
Histidine  His  H 
Isoleucine  Ile  I 
Leucine  Leu  L 
Lysine  Lys  K 

Methionine  Met  M 
Proline  Pro  P 
Serine  Ser  S 

Threonine  Thr  T 
Tryptophan  Trp  W 

Tyrosine  Tyr  Y 
Valine  Val  V 

Phosphotyrosine  Ptr  y 
Phosphothreonine Tpo  p 

Phosphoserine  Sep  s 
Sulphotyrosine  Tys  z 

Mutate multiple residues  
This option does in many ways the same as the Mutate residue option. The difference is 
that with this option you can make multiple mutations in one structure, such as double, 
triple, ... mutations on more than one residue position.  

 
'Mutate multiple residues' allows to select multiple residues and indicate the replacing 
amino acids for multiple mutations in one structure. 

The main differences in the menus that are presented are:  

Residue selection menu 

 Here you can select multiple residues to mutate with FoldX  

http://switch.vub.ac.be/foldxyasara/index.php/FoldX_tools_in_YASARA#Mutate_residue
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Residue selection menu allows to select multiple residues to mutate 
simultaneously 

 

New amino acids 

 In this text box you have to type the new amino acids in sequential order 
in 1-lettercode as given in the table above. E.g. if you selected in the first 
menu residues T13, A30, R54 and W67, you indicated that you want to 
make four simultaneous mutations in the structure. In the text box you 
then type four replacing amino acids e.g. SLEY. This means that 
following mutations will be made: T13S, A30L, R54E and W67Y. Note 
that the amino acid 1-lettercode is case sensitive (!), since this allows for 
modified amino acids to be handled by FoldX (see the amino acid table 
above).  

http://switch.vub.ac.be/foldxyasara/index.php/File:Mutate_multiple_residues_1.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Mutate_multiple_residues_1.png�


 24

 
In the text box we type in N to C order the replacement residues of those we 
selected in the previous residue selection menu 

The rest of the menus work in the same way as in Mutate residue.  

After the mutation design the Repaired structure (if selected) and all the runs of the 
mutations will be loaded into YASARA as new Objects. All of these will be structurally 
aligned (superposition) using the Mustang algorithm for direct comparison.  

The requested output (stability change, interaction energy change) will be plotted in the 
YASARA console. The same results are also listed in a tab-delimited text file called 
FOLDXSUMMARY.out in the cache folder. This file can be saved in a custom folder 
together with all other output files using the option Save last calculation.  

All models and repaired structures can be saved as PDB files by clicking (for each object 
separately):  

File > Save as > PDB File 

Or you can save the entire YASARA scene keeping all Objects, colors and orientation 
including superposition by clicking:  

File > Save as > YASARA Scene 

To get the most accurate results, we recommend to use the Repair object command first.  

http://switch.vub.ac.be/foldxyasara/index.php/File:Mutate_multiple_residues_2.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Mutate_multiple_residues_2.png�
http://switch.vub.ac.be/foldxyasara/index.php/FoldX_tools_in_YASARA#Mutate_residue
http://switch.vub.ac.be/foldxyasara/index.php/FoldX_tools_in_YASARA#Save_last_calculation
http://switch.vub.ac.be/foldxyasara/index.php/FoldX_tools_in_YASARA#Repair_object
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Build homology model  

When a homology modeling task is desired or the number of mutations to make is too 
large for the option Mutate multiple residues, the 'Build homology model' option is your 
choice for the job.  

'Build homology model' will run FoldX BuildModel to model a given target sequence on a 
selected template structure object. 

When this option is selected the following menus are presented:  

Object selection menu 

 A single object that serves as the template structure can be selected here  

Select alignment file 

 The alignment file is a plain text file containing only two lines. The first 
line represents the sequence of the template protein. This can also be just a 
part of the template protein, as long as this sequence exists in the template 
structure. FoldX will always model in the context of the whole structure, 
so the part of the template that you did not type in the alignment file will 
still be in the final model. The second line holds the target sequence of the 
protein to be modeled. This sequence has to be of the same length as the 
sequence of the template on the first line and can only contain valid 1-
letter amino acid characters. Modeling insertions and deletions is not yet 
possible in the current version of FoldX.  

Tip: Extract the sequence of the template structure using the YASARA command ListRes or 
click 
Analyze > List > Residue to get the exact amino acid sequence of the template structure. 
Copy and paste the template sequence (or just the part you want to align) from the 
Console to a text editor on the first line.  
Then, align it with the target sequence by typing the target sequence on the second line. 
Save the alignment to a file and feed this file to the plugin. 

Example alignment file:  

GSSPKAVALYSFAGEESGDLPFRKGDVITILKKSDSQNDWWTGRVNGREGIFPANYVELV 
GSSPRAVALYSYAGDDSGDLPFRKGDLIRGLKKSDSQSDNWTGRMNGRKMIFPANYVELV 

First line contains the template sequence (does not have to be the full sequence of the 
template structure). 
Second line contains the target sequence to be modeled.  

http://switch.vub.ac.be/foldxyasara/index.php/FoldX_tools_in_YASARA#Mutate_multiple_residues
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The rest of the menus work in the same way as in the Mutate residue option.  

The resulting homology models (more than one if more than one run) will be loaded as 
YASARA Objects.  

Save last calculation  

This option lets you specify a target folder and/or filename prefix for the beginning of all 
files of the last calculation to be saved. A calculation is either a Repair, Alanine scan, 
BuildModel (Mutate residue, Mutate multiple residues, Build homology model), 
Interaction energy, Stability.  

The first selection window lets you choose whether you want to save all files or just the 
FOLDXSUMMARY.out file. This file contains mutation energies and is only created after 
an alanine scan or a mutation run.  

In the next selection window you can either select a single folder or a folder and filename 
prefix:  

 Folder: E.g. selecting c:\testrun\ will save all last calculation files to that folder.  
 Folder with filename prefix: E.g. selecting c:\testrun\MyRun will save all last 

calculation files to the testrun folder and put MyRun_ before every filename. In 
this way, it is possible to save more than one calculation in the same folder by 
using different prefixes.  

'Save last calculation' saves the FoldX output files of the last calculation to a user-
specified folder with optional filename prefix. 

For more information on the content and format of FoldX output files we refer to the 
FoldX manual that can be downloaded from foldx.crg.es.  

Configure plugin  
See the section Installation and first use for explanation of this option.  

http://switch.vub.ac.be/foldxyasara/index.php/FoldX_tools_in_YASARA#Mutate_residue
http://foldx.crg.es/
http://switch.vub.ac.be/foldxyasara/index.php/Installation_and_first_use
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Training exercises 
Introduction 

In this section we will let the FoldX plugin loose on some real world examples and give 
you step-by-step instructions on how to proceed and analyze the results. We will use the 
P53 tumor suppressor protein as our example molecule. In a first exercise we will show 
you how to make a point mutation with FoldX and how to determine if the mutation is 
stabilizing or destabilizing for the P53 structure. In a second exercise we will design a 
mutation in the P53 structure at the DNA binding interface and determine how the 
mutation affects the interaction energy of P53 with the DNA strand.  

FoldX energies  
Before we start, some basic information about FoldX energies is necessary.  

First of all, FoldX energies are expressed in kcal/mol.  

The main focus of FoldX is the prediction of free energy changes, e.g. what happens to 
the free energy of the protein when we mutate an Asp to a Tyr? FoldX will then calculate 
the free energy of the wild type (WT) and the mutant (MT) and make the difference:  

ΔΔG(change) = ΔG(MT) - ΔG(WT)  

 
FoldX is trained to make ΔΔG(change) approach experimental values. It is important to 
realize that ΔG(WT) and ΔG(MT) are meaningless numbers as such. These do not 
correlate with experimental values. Only ΔΔG(change) does.  

As a rule of thumb we use:  

ΔΔG(change) > 0 : the mutation is destabilizing  

ΔΔG(change) < 0 : the mutation is stabilizing  

The error margin of FoldX is approximately 0.5 kcal/mol, so changes in that range are 
insignificant.  

Minimizing the structure  

FoldX assumes that the starting structure has been energy minimized. Although crystal 
structures with high resolution often represent a low energy form, FoldX performs best 
when we minimize it just before we do the predictions. This FoldX procedure is called 
RepairPDB and should be done on each structure you want to perform calculations on.  
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Download and open the YASARA scene 2AC0.sce in YASARA. This is a part of a 
tetrameric complex of the transcription factor P53 bound to DNA. I removed 3 of the 4 
P53 structures for simplicity and visualized some nice features.  

Load the scene with:  

File > Load > YASARA Scene 

 
P53 monomer bound to DNA 

To Repair (or minimize) the structure with FoldX go to:  

Analyze > FoldX > Repair object 

 

http://switch.vub.ac.be/foldxyasara/index.php/File:Training_1.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Training_1.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Training_2.png�
http://switch.vub.ac.be/foldxyasara/images/0/0a/2AC0.sce
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Select the object for repairing 

And select the only object in the list. Repairing a structure can take a few minutes 
depending on the size of the protein.  

When the Repair is finished, the Repaired Object is placed in Object 2 (see top right 
corner) and superposed with the original Object 1. Take a look at the sidechains and see 
what FoldX has done while Repairing.  

If you feel the repair takes too long (more than 10 minutes) due to a slow computer, 
download and open this YASARA Scene with the Repaired Object.  

File > Load > YASARA Scene 

Because we will continue working with this Repaired Object, we can now hide the entire 
Object 1 by toggling the Visibility column in the top right corner head-up display (HUD).  

As repairing can take quite some time, it is a good idea to save each repaired 
structure for re-use later on. Save the repaired structure as a PDB file with:  

File > Save as > PDB file 

and select the second Object in the leftmost Sequence column.  

http://switch.vub.ac.be/foldxyasara/index.php/File:Training_2.png�
http://switch.vub.ac.be/foldxyasara/images/2/24/2AC0_Repaired.sce
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Predict effect of a point mutation on protein structure 
stability  

Turn on all the atoms in the DNA chain. These are chains/molecules G and H.  

View > Show atoms in > Molecule > Name > G and H 

Show the sidechain of Ala159 in the core of P53 by searching for it in the sequence 
selector (in Object 2, not Object 1!), right-click on it and go to:  

Show atoms > Residue sidechain and CA 

 
Hovering the mouse at the bottom of the screen will open the sequence selector. Search 
for Ala 159 in Object 2, not Object 1! 

http://switch.vub.ac.be/foldxyasara/index.php/File:Training_3.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Training_3.png�
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Right-clicking on Ala159 opens the residue-context menu 

Zoom in on the Ala159 by keeping the CTRL button pressed and at the same time left click 
on it in the sequence selector. 

We are going to mutate this residue to the largest natural amino acid, tryptophan (W).  

Right-click again on Ala159 in Object 2 in the sequence selector and go to:  

FoldX > Mutate residue 

 
Right-click on Ala159 and select "FoldX > Mutate residue" to mutate this specific 
residue 

A number of menus is now presented and here is what you need to do in each menu:  

http://switch.vub.ac.be/foldxyasara/index.php/File:Training_4.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Training_4.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Training_5.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Training_5.png�
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1. Only select Calculate stability change  
2. Select Trp  
3. 'Move neighbours' and 'Show VdW clashes in WT and mutant'  
4. Don't change any numerical options in the last menu  

 
View of the first options menu with Move neighbours and VdW clashes selected 

More information on all these selection menus is explained in detail in the mutate residue 
section of the guide.  

Analyze the mutation  

FoldX has mutated the Ala to Trp and the structure with the Trp mutation has been 
loaded in the next Object (3) and is superposed with the wild type (WT, Object 2). We 
selected an option to show the VdW clashes in WT and mutant. The atoms that give rise 
to steric clashes are colored in red. Toggle the Visibility of Object 2 (WT) and Object 3 
(mutant) and see how many clashes we introduced by mutating the Ala to Trp. 

http://switch.vub.ac.be/foldxyasara/index.php/File:Training_6.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Training_6.png�
http://switch.vub.ac.be/foldxyasara/index.php/FoldX_tools_in_YASARA#Mutate_residue
http://switch.vub.ac.be/foldxyasara/index.php/FoldX_tools_in_YASARA#Mutate_residue
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Zoomed-in-view on the original Ala159, no Vander Waals clashes here 
 

 
Zoomed-in-view on the mutated Ala159Trp, lots of red Vander Waals clashes here 
 

Van der Waals clashes are red colored atoms. Do you see a difference around the mutation 
site between WT and mutant? Toggle the Visibility of WT and 
mutant to see the differences. 

Open the Console by pressing the spacebar twice and see the free energy change of the 
mutation. Anything above a change of +0.5kcal/mol is already assumed to be 
destabilizing.  

Is the Ala195Trp mutation destabilizing or stabilizing? 

http://switch.vub.ac.be/foldxyasara/index.php/File:Training_7.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Training_7.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Training_8.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Training_8.png�
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In the console (to open press spacebar twice), we see an energy change of +29 kcal/mol. 
Clearly, this is severely destabilising the structure 

Predict effect of a point mutation on protein-DNA 
binding  
Hide Object 3 by toggling its Visibility so that only Object 2 (the repaired WT) is visible. 
First turn on all atoms in the molecules G and H (DNA) again as you did previously, 
because the FoldX run has hidden it (it rearranged the view to show the VdW clashes).  

Show the sidechain of Arg273 of Object 2 by searching for it in the sequence selector, 
then right-click on it and go to:  

Show atoms > Sidechain and CA 
 
Zoom in on Arg273 

Notice how the positively charged Arginine is making an electrostatic interaction 
with the negative phosphate from the DNA backbone.  

http://switch.vub.ac.be/foldxyasara/index.php/File:Training_9.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Training_9.png�
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R273 makes an electrostatic interaction with the DNA phosphate groups. 

Let's see what would happen to the interaction energy between the DNA and P53 when 
we mutate this Arginine to Alanine.  

Right-click on this Arg273 in the sequence selector and go to:  

FoldX > Mutate residue 

A number of menus is now presented and here is what you need to do in each menu:  

1. Select Calculate interaction energy change  
2. Select Ala  
3. 'Move neighbours' and 'Show disrupted and new hydrogen bonds'  
4. Don't change any numerical options in the last menu  

http://switch.vub.ac.be/foldxyasara/index.php/File:Training_10.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Training_10.png�
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View of the first options menu with "Show new and disrupted hydrogen bonds" selected. 

Toggle the Visibility between this mutant and the WT structure and see how the 
hydrogen bonding changes.  

Check the output in the Console to see what the change in interaction energy is between 
P53 and DNA chain G upon mutation. 

 

 
We see that the mutation decreases the interaction with DNA strand G by approximately 
1 kcal/mol (we lost 1 hydrogen bond). 
 
Instead of DNA-protein, FoldX can of course also calculate interaction energy changes in 
protein-protein or peptide-protein complexes. 

http://switch.vub.ac.be/foldxyasara/index.php/File:Training_11.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Training_11.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Training_12.png�
http://switch.vub.ac.be/foldxyasara/index.php/File:Training_12.png�
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Troubleshooting 
Advance note  
Whenever you run into a problem or you experience a crash, always check first if you 
have carefully followed the installation instructions and you are using the latest version 
of the plugin and the latest version of YASARA. If the problem persists, check if the 
issue is listed here. If not, don't hesitate to contact us.  

Analyze menu does not open  

As explained in the first use section of this documentation website, the Analyze menu 
only becomes active when a structure is loaded. So open a structure with e.g.:  

File > Load > PDB file 

Now the Analyze menu is active and a FoldX submenu should be present.  

FoldX menu does not show up  
You are using an old YASARA version  

The plugin only works from YASARA 10.11.22 and higher. Please upgrade to the 
latest version.  

You forgot to download and install the plugin  
It is not enough to install YASARA and FoldX to be able to run FoldX from 
YASARA. You need to download and unzip the plugin zip file from the 
homepage or HERE. Please consult the Installation and first use section for details 
on installing and unzipping the plugin in the correct location.  

You are using Windows Vista or Windows 7  
This workaround comes from the YASARA documentation:  
YASARA does not have write permissions in its own directory. Especially 
Windows Vista/7 has a deep sitting problem dealing with permissions, i.e. even if 
you installed YASARA in the 'Program Files' folder, providing all the required 
authorization, Windows may still prevent it from running correctly. To fix this 
issue, right-click on the 'yasara' folder, then click Properties > Security, select 
group 'Users', click 'Edit', tick 'Full control - Allow', click 'Apply'. Verify that 
there is now really a hook in the 'Allow' column for 'Full control'. If you do not 
have the required administrator privileges to perform this operation, simply install 
YASARA in your home directory.  

http://www.yasara.org/downloads.htm
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Unchecking the Move neighbours option results in a 
crash  

When Move neighbours is unchecked, FoldX does not generate a reference wild type 
structure, as the plugin expects. This will result in a plugin crash. This should be fixed in 
the next FoldX release. In the meantime, always leave the Move neighbours option 
checked. If you really don't want neighbouring residues to move, you can use the Fix 
residue option to freeze residues manually using:  

Analyze > FoldX > Fix residue 

Build homology model issues  
Error - The given template sequence in the sequence file was not found in the template 
structure.  

If you are sure that the alignment file contains the correct template sequence, check the 
structure for multiple residues with the same residue number (e.g. 1EJG residue 25). If 
multiple residues with the same residue number are present, these additional residues will 
make the structure-extracted template sequence longer and the plugin will raise an error 
because the structure contains more residues than the provided template sequence.  

Solution 1: Run a FoldX RepairPDB first. You can do this manually from Analyze > FoldX > 
Repair object. 
Alternatively you can check the Repair option in one of the selection menus from the 
Build homology model command.  
Repairing the structure will only keep the residue that occurs first in the PDB file and 
delete the next one(s). 
 
Solution 2: Manually delete the additional residues so that each residue number occurs 
only once. 
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Author and contact support 
 
The FoldX plugin for YASARA was developed and is being maintained by Joost Van 
Durme, PhD at the VIB Switch Laboratory, Vrije Universiteit Brussel, Belgium. 
 
For support write an e-mail to joost.vandurme@switch.vib-vub.be 
 
Cheers ☺ 

mailto:joost.vandurme@switch.vib-vub.be
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